Menu Management Processing Delays

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 15:42 EDT

Update

The system is steadily processing its backlog of changes, and we will continue to monitor the situation.
Posted Jul 07, 2025 - 14:13 EDT

Update

The system is steadily processing its backlog of changes, and we will continue to monitor the situation.
Posted Jul 07, 2025 - 10:51 EDT

Monitoring

We are actively monitoring delays in processing menu updates. Changes may not immediately be reflected in the menu.
Posted Jul 07, 2025 - 09:00 EDT
This incident affected: Menu Services.