Payment Processor Issues: Olo Pay Kiosk

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 11:09 EDT

Monitoring

We are seeing Adyen transactions return to normal and continue to monitor the situation.
Posted Aug 21, 2025 - 10:54 EDT

Identified

Adyen has identified an issue on their end.
Posted Aug 21, 2025 - 10:33 EDT

Investigating

We're detecting elevated errors processing payments through Olo Pay Kiosk. Ordering may be affected at locations using Olo Pay Kiosk as their payment provider.
Posted Aug 21, 2025 - 10:11 EDT
This incident affected: Partners (Payment Processing Partners).