Payment Processor Issues: FreedomPay

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 15:22 EST

Monitoring

We are seeing FreedomPay transactions return to normal and continue to monitor the situation.
Posted Nov 06, 2025 - 15:09 EST

Investigating

We're detecting elevated errors processing payments through FreedomPay. Ordering may be affected at locations using FreedomPay as their payment provider.
Posted Nov 06, 2025 - 14:44 EST
This incident affected: Partners (Payment Processing Partners).